Showing results for 
Search instead for 
Did you mean: 

ERROR 25012: Invalid file format


I recently had to reinstall DemandTools, and have had a number of issues. First, for some reason it took a number of tries signing into my org before it was actually signed in. It kept taking me back to the sign-in screen. I got that taken care of.

My next problem came when I tried to run a scheduled job "now" (because it hasn't run with the computer issues I was having). It fails immediately. When I check the log, it has ERROR 25012: Invalid file format.

There's some other stuff there too, but it's long and I didn't really want to post the whole thing, not knowing which parts would be relevant. The log has a number of lines referencing some long string .java:(some number).

Let me know if any additional information would be helpful. This is a job that has successfully run in the past without any issues. I did run the update and am on version 5.28 currently.


Validity Team Member
Validity Team Member

Hi @RayneJSA !

For this issue/inquiry, I would recommend opening a ticket with Support. You can do this by going to this link: 

If you'd like us to look into why you had to log into your CRM multiple times before it worked, I would create a seperate ticket for that issue as well.

Please also provide the schedule log as well as the app logs:

  • You can find the schedule logs by going to Application > Audit/Restore/Schedule Logs > Schedule Logs
  • You can find instructions on how to get the app logs by going here.
Anthony Lardiere Jr
Senior Customer Success Manager