Showing results for 
Search instead for 
Did you mean: 

Can't update my DemandTools V to 24.1


I use two different computers for work - my laptop and my desktop - both on windows.  I was running DemandTools V v22 on both and when I opened it up I was notified there was an update to v24.1.  I downloaded the update and tried to install it on both machines.  On my desktop it installed no problem.

On my laptop, though, the notfication comes up and I click download, then I get a notification to restart the application.  I click Restart.  I get the notifications asking if I want to allow this application to make changes to my device and I confirm those.  Then it starts to install and I get an error saying Validity DemandTools cannot be closed.  Please close it manually and click retry to continue.  

No matter how many times I click retry I can't get past this stage.  I end up having to cancel out of it and then I get a message that says "Failed to uninstall old application files.  please try running the installer again: 2".  No matter how many times I run it I get into the same error loop.

Has anyone else encountered this issue?  If so, how did you resolve?

I have a scheduled job that runs daily on my local machine (laptop) and thought maybe that was preventing it from being closed but I went in and made that job inactive and still get the same error message.  I've thought about uninstalling the whole thing and doing a fresh install but I don't want to lose my scenarios or scheduled job that I have set up.

Let me know if you have a fix that will allow me to upgrade without losing anything.  Thanks!


Validity Team Member
Validity Team Member

Hi @HarveyDanger ,

I went ahead and created a Support ticket for you as they are the best team to resolve this.  You should get an email shortly with the ticket number.

Anthony Lardiere Jr
Senior Customer Success Manager

Frequent Contributor

@HarveyDanger I have a Mac and Windows laptop I have to update, and there have been a coulple times I've had issues on my Mac.  Instead of using the in app update process, I just download the latest version of the app from the website and install it that way and it works.